<!DOCTYPE html>
<html lang="en-US" xmlns:fb="http://ogp.me/ns/fb#">

<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="http://www.lovellchronicle.com/xmlrpc.php">

<title>Mustangs run gauntlet at Legion C State to place second</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Feed" href="http://www.lovellchronicle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Comments Feed" href="http://www.lovellchronicle.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Mustangs run gauntlet at Legion C State to place second Comments Feed" href="http://www.lovellchronicle.com/2018/07/mustangs-run-gauntlet-at-legion-c-state-to-place-second/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.lovellchronicle.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.7"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='tortuga-custom-fonts-css'  href='http://www.lovellchronicle.com/wp-content/themes/tortuga/assets/css/custom-fonts.css?ver=20180413' type='text/css' media='all' />
<link rel='stylesheet' id='wppa_style-css'  href='http://www.lovellchronicle.com/wp-content/plugins/wp-photo-album-plus/theme/wppa-style.css?ver=6-9-06-008' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://www.lovellchronicle.com/wp-includes/css/dashicons.min.css?ver=4.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='tortuga-stylesheet-css'  href='http://www.lovellchronicle.com/wp-content/themes/tortuga/style.css?ver=1.6' type='text/css' media='all' />
<style id='tortuga-stylesheet-inline-css' type='text/css'>
.site-title, .site-description { position: absolute; clip: rect(1px, 1px, 1px, 1px); width: 1px; height: 1px; overflow: hidden; }
</style>
<link rel='stylesheet' id='genericons-css'  href='http://www.lovellchronicle.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='themezee-related-posts-css'  href='http://www.lovellchronicle.com/wp-content/themes/tortuga/assets/css/themezee-related-posts.css?ver=20160421' type='text/css' media='all' />
<link rel='stylesheet' id='tortuga-slider-css'  href='http://www.lovellchronicle.com/wp-content/themes/tortuga/assets/css/flexslider.css?ver=20170421' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-widget-social-icons-styles-css'  href='http://www.lovellchronicle.com/wp-content/plugins/jetpack/modules/widgets/social-icons/social-icons.css?ver=20170506' type='text/css' media='all' />
<link rel='stylesheet' id='__EPYT__style-css'  href='http://www.lovellchronicle.com/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css?ver=12.0' type='text/css' media='all' />
<style id='__EPYT__style-inline-css' type='text/css'>

                .epyt-gallery-thumb {
                        width: 33.333%;
                }
                
</style>
<link rel='stylesheet' id='social-logos-css'  href='http://www.lovellchronicle.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.lovellchronicle.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.3.2' type='text/css' media='all' />
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var samAjax = {"ajaxurl":"http:\/\/www.lovellchronicle.com\/wp-content\/plugins\/simple-ads-manager\/sam-ajax.php","loadurl":"http:\/\/www.lovellchronicle.com\/wp-content\/plugins\/simple-ads-manager\/sam-ajax-loader.php","load":"","mailer":"1","clauses":"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","doStats":"1","container":"sam-container","place":"sam-place","ad":"sam-ad"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-content/plugins/simple-ads-manager/js/sam-layout.min.js?ver=2.9.8.125'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-content/themes/tortuga/assets/js/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-content/themes/tortuga/assets/js/navigation.js?ver=20160719'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-content/themes/tortuga/assets/js/jquery.flexslider-min.js?ver=2.6.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tortuga_slider_params = {"animation":"slide","speed":"7000"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-content/themes/tortuga/assets/js/slider.js?ver=20170421'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-includes/js/jquery/jquery.form.min.js?ver=4.2.1'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-content/plugins/wp-photo-album-plus/js/wppa-utils.min.js?ver=6-9-06-008'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-includes/js/jquery/ui/button.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-content/plugins/wp-photo-album-plus/js/wppa.min.js?ver=6-9-06-008'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-content/plugins/wp-photo-album-plus/js/wppa-slideshow.min.js?ver=6-9-06-008'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-content/plugins/wp-photo-album-plus/js/wppa-ajax-front.min.js?ver=6-9-06-008'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-content/plugins/wp-photo-album-plus/js/wppa-popup.min.js?ver=6-9-06-008'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-content/plugins/wp-photo-album-plus/wppa-init.en.js?ver=129'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"http:\/\/www.lovellchronicle.com\/wp-admin\/admin-ajax.php","security":"d51b2bb815","gallery_scrolloffset":"20","eppathtoscripts":"http:\/\/www.lovellchronicle.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","epresponsiveselector":"[\"iframe[src*='youtube.com']\",\"iframe[src*='youtube-nocookie.com']\",\"iframe[data-ep-src*='youtube.com']\",\"iframe[data-ep-src*='youtube-nocookie.com']\",\"iframe[data-ep-gallerysrc*='youtube.com']\"]","epdovol":"1","version":"12.0","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","ytapi_load":"light","stopMobileBuffer":"1","vi_active":"","vi_js_posttypes":[]};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?ver=12.0'></script>
<link rel='https://api.w.org/' href='http://www.lovellchronicle.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.lovellchronicle.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.lovellchronicle.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Aron Ronald Schmidt' href='http://www.lovellchronicle.com/2018/07/aron-ronald-schmidt/' />
<link rel='next' title='Lockhart Ranch and Horseshoe Bend get a new look' href='http://www.lovellchronicle.com/2018/07/lockhart-ranch-and-horseshoe-bend-get-a-new-look/' />
<meta name="generator" content="WordPress 4.9.7" />
<link rel="canonical" href="http://www.lovellchronicle.com/2018/07/mustangs-run-gauntlet-at-legion-c-state-to-place-second/" />
<link rel='shortlink' href='https://wp.me/p1AGQQ-3D1' />
<link rel="alternate" type="application/json+oembed" href="http://www.lovellchronicle.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.lovellchronicle.com%2F2018%2F07%2Fmustangs-run-gauntlet-at-legion-c-state-to-place-second%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.lovellchronicle.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.lovellchronicle.com%2F2018%2F07%2Fmustangs-run-gauntlet-at-legion-c-state-to-place-second%2F&#038;format=xml" />

<!-- This site is using AdRotate v4.12.3 to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->

<!-- Start Of Script Generated By cforms v11.8 [Oliver Seidel | www.deliciousdays.com] -->
<link rel="stylesheet" type="text/css" href="http://www.lovellchronicle.com/wp-content/plugins/cforms/styling/fancy_white.css" />
<script type="text/javascript" src="http://www.lovellchronicle.com/wp-content/plugins/cforms/js/cforms.js"></script>
<!-- End Of Script Generated By cforms -->


		<style type="text/css">		
		/* Ticker Styling */
		#ticker-wrapper *{margin:0}
		#ticker-wrapper.has-js {
			padding-left: 20px;
			width: 800px;
			height: 50px;
			display: block;
			background-color: ;
			font-size: 12px;
		}
		#ticker {
			width: 715px;
			height: 50px;
			display: block;
			float: left;
			position: relative;
			overflow: hidden;
			background-color: ;
		}
		#ticker-title {
			float: left; 	
			color: ;
			font-weight: bold;
			background-color: ;
			text-transform: uppercase;
			font-size: 12px;
			height: 50px;
			line-height: 50px;
						
		}
		
		#ticker-content {
			margin: 0px;
			float: left;
			position: absolute;
			color: ;
			font-weight: bold;
			background-color: ;
			overflow: hidden;
			white-space: nowrap;
			font-size: 12px;
			line-height: 50px;
		}
		#ticker-content:focus {
			none;
		}
		#ticker-content a {
			text-decoration: none;
			font-size: 12px;	
			color: ;
		}
		#ticker-content a:hover {
			text-decoration: underline;				
			color: ;
		}
		#ticker-swipe {
			position: absolute;
			top: 0px;
			left: 1200px;
			background-color: ;
			display: block;
			width: 800px;
			height: 50px; 
		}
		#ticker-swipe span {
			margin-left: 1px;
			background-color: ;
			border-bottom: 1px solid ;
			height: 30px;
			width: 7px;
			display: block;
		}
		.news-date {
			font-size: 11px;
			color: ;
			font-weight: normal;
		}
		#ticker-controls{list-style-type:none;float:right;padding:15px 10px 0 0}
		#ticker-controls LI{margin-left:5px;float:left;cursor:pointer;height:16px;width:16px;display:block;padding:0}
		#ticker-controls LI#play-pause{background-image:url(http://www.lovellchronicle.com/wp-content/plugins/news-ticker-pluginleopedia/images/controls.png);background-position:32px 16px}
		#ticker-controls LI#play-pause.over{background-position:32px 32px}
		#ticker-controls LI#play-pause.down{background-position:32px 0}
		#ticker-controls LI#play-pause.paused{background-image:url(http://www.lovellchronicle.com/wp-content/plugins/news-ticker-pluginleopedia/images/controls.png);background-position:48px 16px}
		#ticker-controls LI#play-pause.paused.over{background-position:48px 32px}
		#ticker-controls LI#play-pause.paused.down{background-position:48px 0}
		#ticker-controls LI#prev{background-image:url(http://www.lovellchronicle.com/wp-content/plugins/news-ticker-pluginleopedia/images/controls.png);background-position:0 16px}
		#ticker-controls LI#prev.over{background-position:0 32px}
		#ticker-controls LI#prev.down{background-position:0 0}
		#ticker-controls LI#next{background-image:url(http://www.lovellchronicle.com/wp-content/plugins/news-ticker-pluginleopedia/images/controls.png);background-position:16px 16px}
		#ticker-controls LI#next.over{background-position:16px 32px}
		#ticker-controls LI#next.down{background-position:16px 0}
		.js-hidden{display:none}
		</style>
		<script type="text/javascript">
		jQuery.noConflict();		
		</script>
		<script type="text/javascript" src="http://www.lovellchronicle.com/wp-content/plugins/news-ticker-pluginleopedia/jquery.ticker.min.js"></script>
		<script type="text/javascript">
		jQuery(document).ready(function() {
			jQuery("#newsTicker").ticker({
					titleText: ""
				}
			);		
		});
		</script>
	<script type="text/javascript" src="http://www.lovellchronicle.com/wp-content/plugins/quicktime-embed/qtobject.js"></script>

<script type="text/javascript" >
wppaImageDirectory = "http://www.lovellchronicle.com/wp-content/plugins/wp-photo-album-plus/img/";
wppaPhotoDirectory = "http://www.lovellchronicle.com/wp-content/uploads/wppa/";
wppaNoPreview = "No Preview available";
wppaTxtProcessing = "Processing...";
wppaTxtDone = "Done!";
wppaTxtErrUnable = "ERROR: unable to upload files.";
wppaOutputType = "-none-";
wppaShortcodeTemplate = "&lt;div style=&quot;font-size:0;&quot; &gt;&lt;img id=&quot;ph-347-0&quot; src=&quot;http://www.lovellchronicle.com/wp-content/uploads/wppa/347.png?ver=1&quot;  alt=&quot;06-04-2015__Y1B6867_FunDay.png&quot;  title=&quot;06-04-2015__Y1B6867_FunDay.png&quot;  style=&quot;width:100%;margin:0;&quot; /&gt;&lt;/div&gt;";
wppaShortcodeTemplateId = "347.png";

</script><style data-context="foundation-flickity-css">/*! Flickity v2.0.2
http://flickity.metafizzy.co
---------------------------------------------- */.flickity-enabled{position:relative}.flickity-enabled:focus{outline:0}.flickity-viewport{overflow:hidden;position:relative;height:100%}.flickity-slider{position:absolute;width:100%;height:100%}.flickity-enabled.is-draggable{-webkit-tap-highlight-color:transparent;tap-highlight-color:transparent;-webkit-user-select:none;-moz-user-select:none;-ms-user-select:none;user-select:none}.flickity-enabled.is-draggable .flickity-viewport{cursor:move;cursor:-webkit-grab;cursor:grab}.flickity-enabled.is-draggable .flickity-viewport.is-pointer-down{cursor:-webkit-grabbing;cursor:grabbing}.flickity-prev-next-button{position:absolute;top:50%;width:44px;height:44px;border:none;border-radius:50%;background:#fff;background:hsla(0,0%,100%,.75);cursor:pointer;-webkit-transform:translateY(-50%);transform:translateY(-50%)}.flickity-prev-next-button:hover{background:#fff}.flickity-prev-next-button:focus{outline:0;box-shadow:0 0 0 5px #09F}.flickity-prev-next-button:active{opacity:.6}.flickity-prev-next-button.previous{left:10px}.flickity-prev-next-button.next{right:10px}.flickity-rtl .flickity-prev-next-button.previous{left:auto;right:10px}.flickity-rtl .flickity-prev-next-button.next{right:auto;left:10px}.flickity-prev-next-button:disabled{opacity:.3;cursor:auto}.flickity-prev-next-button svg{position:absolute;left:20%;top:20%;width:60%;height:60%}.flickity-prev-next-button .arrow{fill:#333}.flickity-page-dots{position:absolute;width:100%;bottom:-25px;padding:0;margin:0;list-style:none;text-align:center;line-height:1}.flickity-rtl .flickity-page-dots{direction:rtl}.flickity-page-dots .dot{display:inline-block;width:10px;height:10px;margin:0 8px;background:#333;border-radius:50%;opacity:.25;cursor:pointer}.flickity-page-dots .dot.is-selected{opacity:1}</style><style data-context="foundation-slideout-css">.slideout-menu{position:fixed;left:0;top:0;bottom:0;right:auto;z-index:0;width:256px;overflow-y:auto;-webkit-overflow-scrolling:touch;display:none}.slideout-menu.pushit-right{left:auto;right:0}.slideout-panel{position:relative;z-index:1;will-change:transform}.slideout-open,.slideout-open .slideout-panel,.slideout-open body{overflow:hidden}.slideout-open .slideout-menu{display:block}.pushit{display:none}</style>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Mustangs run gauntlet at Legion C State to place second" />
<meta property="og:url" content="http://www.lovellchronicle.com/2018/07/mustangs-run-gauntlet-at-legion-c-state-to-place-second/" />
<meta property="og:description" content="The Lovell Mustangs American Legion C baseball squad put together a successful run at the Wyoming C State Tournament by sending five teams home in the consolation bracket after losing their first r…" />
<meta property="article:published_time" content="2018-07-26T15:30:07+00:00" />
<meta property="article:modified_time" content="2018-07-26T15:18:19+00:00" />
<meta property="og:image" content="http://www.lovellchronicle.com/wp-content/uploads/2018/07/MustangsC2nd.jpg" />
<meta property="og:image:width" content="350" />
<meta property="og:image:height" content="250" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@Lovell_News" />
<meta name="twitter:text:title" content="Mustangs run gauntlet at Legion C State to place second" />
<meta name="twitter:image" content="http://www.lovellchronicle.com/wp-content/uploads/2018/07/MustangsC2nd.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@Lovell_News" />

<!-- End Jetpack Open Graph Tags -->

		<!-- WPPA+ START Page specific urls and browser dependant data -->
		<script type="text/javascript" >
		
wppaImageDirectory = "http://www.lovellchronicle.com/wp-content/plugins/wp-photo-album-plus/img/";
wppaWppaUrl = "http://www.lovellchronicle.com/wp-content/plugins/wp-photo-album-plus";
wppaIncludeUrl = "http://www.lovellchronicle.com/wp-includes";
wppaAjaxUrl = "http://www.lovellchronicle.com/wp-content/plugins/wp-photo-album-plus/wppa-ajax-front.php";
wppaUploadUrl = "http://www.lovellchronicle.com/wp-content/uploads/wppa";
wppaIsIe = false;
wppaIsSafari = false;
wppaUseSvg = true;
wppaSlideshowNavigationType = "icons";
wppaAudioHeight = 28;
		</script>
		<!-- WPPA+ END Page specific urls -->
<!-- WPPA+ Custom styles -->
<style type="text/css" >
</style>
<!-- Rendering enabled -->
<!-- /WPPA Kickoff -->

	<style>.ios7.web-app-mode.has-fixed header{ background-color: rgba(3,122,221,.88);}</style></head>

<body class="post-template-default single single-post postid-13951 single-format-standard post-layout-two-columns post-layout-columns">

	<div id="page" class="hfeed site">

		<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

		
		<header id="masthead" class="site-header clearfix" role="banner">

			<div class="header-main container clearfix">

				<div id="logo" class="site-branding clearfix">

										
			<p class="site-title"><a href="http://www.lovellchronicle.com/" rel="home"></a></p>

							
			<p class="site-description">Delivering weekly news and breaking updates in from scenic Lovell, Wyoming.</p>

		
				</div><!-- .site-branding -->

				<div class="header-widgets clearfix">

					
				</div><!-- .header-widgets -->

			</div><!-- .header-main -->

			<div id="main-navigation-wrap" class="primary-navigation-wrap">

				<nav id="main-navigation" class="primary-navigation navigation container clearfix" role="navigation">

					
					<ul id="menu-site-map" class="main-navigation-menu"><li id="menu-item-12690" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-12690"><a href="http://www.lovellchronicle.com">Home</a></li>
<li id="menu-item-6" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6"><a href="http://www.lovellchronicle.com/topics/news/">News</a></li>
<li id="menu-item-9" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-9"><a href="http://www.lovellchronicle.com/topics/sports/">Sports</a></li>
<li id="menu-item-7" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7"><a href="http://www.lovellchronicle.com/topics/obituaries/">Obituaries</a></li>
<li id="menu-item-4241" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4241"><a href="http://www.lovellchronicle.com/special-sections/">Special Sections</a></li>
<li id="menu-item-576" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-576"><a href="http://www.lovellchronicle.com/topics/history-2/">History</a></li>
<li id="menu-item-7034" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-7034"><a href="http://www.lovellchronicle.com/contact-us/">Contact us</a>
<ul class="sub-menu">
	<li id="menu-item-12711" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12711"><a href="http://www.lovellchronicle.com/wp-admin/">WP Login</a></li>
</ul>
</li>
<li id="menu-item-4390" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4390"><a target="_blank" href="http://lovellchronicle.wy.newsmemory.com/#new_tab">E-edition login</a></li>
</ul>				</nav><!-- #main-navigation -->

			</div>

		</header><!-- #masthead -->

		
		
			<div id="headimg" class="header-image">

			
				<a href="http://www.lovellchronicle.com/wp-content/uploads/2017/07/ChronicleFlag3.png">
					<img src="http://www.lovellchronicle.com/wp-content/uploads/2017/07/cropped-cropped-ChronicleFlag3.png" srcset="http://www.lovellchronicle.com/wp-content/uploads/2017/07/cropped-cropped-ChronicleFlag3.png 1920w, http://www.lovellchronicle.com/wp-content/uploads/2017/07/cropped-cropped-ChronicleFlag3-150x50.png 150w, http://www.lovellchronicle.com/wp-content/uploads/2017/07/cropped-cropped-ChronicleFlag3-300x100.png 300w, http://www.lovellchronicle.com/wp-content/uploads/2017/07/cropped-cropped-ChronicleFlag3-768x256.png 768w, http://www.lovellchronicle.com/wp-content/uploads/2017/07/cropped-cropped-ChronicleFlag3-1024x341.png 1024w" width="1920" height="639" alt="">
				</a>

			
			</div>

		
		<div id="content" class="site-content container clearfix">

	<section id="primary" class="content-single content-area">
		<main id="main" class="site-main" role="main">
				
		
<article id="post-13951" class="post-13951 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-sports tag-1542 tag-american-legion tag-baseball tag-lovell tag-lovell-mustangs tag-wyoming">

	<img width="350" height="250" src="http://www.lovellchronicle.com/wp-content/uploads/2018/07/MustangsC2nd.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="http://www.lovellchronicle.com/wp-content/uploads/2018/07/MustangsC2nd.jpg 350w, http://www.lovellchronicle.com/wp-content/uploads/2018/07/MustangsC2nd-150x107.jpg 150w, http://www.lovellchronicle.com/wp-content/uploads/2018/07/MustangsC2nd-300x214.jpg 300w" sizes="(max-width: 350px) 100vw, 350px" data-attachment-id="13953" data-permalink="http://www.lovellchronicle.com/2018/07/mustangs-run-gauntlet-at-legion-c-state-to-place-second/mustangsc2nd/" data-orig-file="http://www.lovellchronicle.com/wp-content/uploads/2018/07/MustangsC2nd.jpg" data-orig-size="350,250" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="MustangsC2nd" data-image-description="" data-medium-file="http://www.lovellchronicle.com/wp-content/uploads/2018/07/MustangsC2nd-300x214.jpg" data-large-file="http://www.lovellchronicle.com/wp-content/uploads/2018/07/MustangsC2nd.jpg" />
	<header class="entry-header">

		<h1 class="entry-title">Mustangs run gauntlet at Legion C State to place second</h1>
		<div class="entry-meta"><span class="meta-date"><a href="http://www.lovellchronicle.com/2018/07/mustangs-run-gauntlet-at-legion-c-state-to-place-second/" title="9:30 am" rel="bookmark"><time class="entry-date published updated" datetime="2018-07-26T09:30:07+00:00">July 26, 2018</time></a></span><span class="meta-author"> <span class="author vcard"><a class="url fn n" href="http://www.lovellchronicle.com/author/chronicleadmin/" title="View all posts by ChronicleAdmin" rel="author">ChronicleAdmin</a></span></span><span class="meta-category"> <a href="http://www.lovellchronicle.com/topics/news/" rel="category tag">News</a>, <a href="http://www.lovellchronicle.com/topics/sports/" rel="category tag">Sports</a></span><span class="meta-comments"> <a href="http://www.lovellchronicle.com/2018/07/mustangs-run-gauntlet-at-legion-c-state-to-place-second/#respond">Leave a comment</a></span></div>
	</header><!-- .entry-header -->

	<div class="entry-content clearfix">

		<p>The Lovell Mustangs American Legion C baseball squad put together a successful run at the Wyoming C State Tournament by sending five teams home in the consolation bracket after losing their first round game, making it all the way to the championship game.</p>
<p>The Mustangs fell to Laramie 7-5 on July 17 in the first round of the tournament. Branson Robison, Tyson Christiansen and Carlos Rodriguez led Lovell with two hits each. Cason James led the team with two RBIs.</p>
<p>CJ Pickett pitched five innings for the ‘Stangs, striking out five Laramie batters. Nate Minemyer pitched one inning for Lovell, fanning two.</p>
<p>“It just came down to we had too many errors,” coach Kelly Spann said. “We had chances to put points up but never could get that big hit. Three times we had bases loaded and only put up five runs. CJ pitched a great game, only giving up five hits. I told the boys after the game that we didn’t lose that game, we gave it to Laramie.”</p>
<p>With the loss, the Mustangs faced Casper Wednesday evening, July 18, in an elimination game. Lovell defeated Casper 14-4 to stay alive in the tournament.</p>
<p>Rodriguez ripped three hits to lead Lovell. Dallen Mangus and Robison led the team with three RBIs apiece.</p>
<p>Cale Wright started on the mound and pitched three innings, striking out two Casper batters. Irving Castro relieved Wright and pitched two innings, fanning three.</p>
<p>“We faced them in the Powell Tournament earlier this year so we kind of knew what to expect,” Spann said. “First inning we started off with two quick outs, then the wheels started to shake. With an error, a walk, then a beaned batter, I thought we were in trouble, but they settled down and got the third out.</p>
<p>“When we came in to bat I told the kids we had to jump on them and not to look back. They responded by putting up four runs. Cale did a good job settling in and pitching. He gave us four good innings, then Irving Castro came in and cleaned up.”</p>
<p>Thursday, the Mustangs avoided elimination again by shutting down Rock Springs 10-0.</p>
<p>Rodriguez and Christiansen rapped two hits apiece to lead the Mustangs. James, Christiansen and Irving Castro each had an RBI in the game.</p>
<p>Dallen Mangus pitched 2 1/3 innings, striking out five Rock Springs batters.<span class="Apple-converted-space"> </span></p>
<p>“Dallen did just what we wanted as he kept them off the bases for the first three innings,” Spann said. “They had a bunch of fast kids that liked to steal bases. Cason set the tone by throwing out their first baserunner trying to steal second. The kid had 42 stolen bases and had never been thrown out till he met up with Cason’s arm. We had to take Dallen out due to pitch count so we could use him later. Carlos relieved him and finally Avery finished things. We played a good defensive game, I thought. We only had two errors and gave up only two hits.”</p>
<p>Friday, Lovell stayed alive once again by defeating Jackson 12-2.</p>
<p>Pickett and Rodriguez led the team with two hits apiece. Pickett and Mangus led the Mustangs with two RBIs apiece.</p>
<p>Minemyer pitched five innings, striking out two Jackson batters.</p>
<p>“Nate pitched a great game for us,” Spann said. “We needed him to give us innings and he did just that. We told the team we needed to ten-run teams so we would have pitching later because we had four games in two days.</p>
<p>“We played another great defensive game. We had no errors. I can’t remember seeing a Mustang team have no errors. In the bottom of the fifth we came in and I told the boys it was time to turn it up and put our foot on their necks till no bubbles came up. They came out and put up 10 to end it.</p>
<p>“At this point people started asking ‘Where is Lovell?’”</p>
<p>In the Friday evening game, Lovell took care of Wheatland 16-1 to advance to the consolation semifinals.</p>
<p>Mangus rapped three hits to lead the team. Mangus and James led the team with three RBIs.</p>
<p>Avery Swiftney pitched five innings for Lovell, striking out three Wheatland batters.</p>
<p>“We won the coin flip but chose away,” Spann said. “I told the boys we are going to jump on them right from the start and end it in five. They came out putting up five runs. Avery was on the hill and the guys behind him did the job. Once again there was no errors. Other coaches and fans started talking about what a great bunch of kids we have. They were playing some great ball on both sides of the plate. Wheatland would put runners on, but we would find a way to get out of the inning.”</p>
<figure id="attachment_13952" style="width: 500px" class="wp-caption alignright"><img data-attachment-id="13952" data-permalink="http://www.lovellchronicle.com/2018/07/mustangs-run-gauntlet-at-legion-c-state-to-place-second/mustangsc/" data-orig-file="http://www.lovellchronicle.com/wp-content/uploads/2018/07/MustangsC.jpg" data-orig-size="500,288" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;1.8&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;iPhone 7 Plus&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1532194505&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;3.99&quot;,&quot;iso&quot;:&quot;40&quot;,&quot;shutter_speed&quot;:&quot;0.0083333333333333&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="MustangsC" data-image-description="" data-medium-file="http://www.lovellchronicle.com/wp-content/uploads/2018/07/MustangsC-300x173.jpg" data-large-file="http://www.lovellchronicle.com/wp-content/uploads/2018/07/MustangsC.jpg" class="size-full wp-image-13952" src="http://www.lovellchronicle.com/wp-content/uploads/2018/07/MustangsC.jpg" alt="" width="500" height="288" srcset="http://www.lovellchronicle.com/wp-content/uploads/2018/07/MustangsC.jpg 500w, http://www.lovellchronicle.com/wp-content/uploads/2018/07/MustangsC-150x86.jpg 150w, http://www.lovellchronicle.com/wp-content/uploads/2018/07/MustangsC-300x173.jpg 300w" sizes="(max-width: 500px) 100vw, 500px" /><figcaption class="wp-caption-text">Posing with their second-place trophy at the Wyoming C State Tournament Saturday in Casper are members of the Lovell Mustangs C Legion team. Pictured are (front row, l-r) Satchel Ginest, Avery Swiftney, Branson Robison, CJ Pickett, Cale Wright, William Spann, (back row) coach Kelly Spann, Cason James, Carlos Rodriguez, Nate Minemyer, Dallen Mangus, Irving Castro, Tyson Christiansen, coach Tobee Christiansen and coach Ken Wright.<br />Courtesy Photo</figcaption></figure>
<p>Saturday, the ‘Stangs defeated Gillette 6-3 to advance to the championship game.</p>
<p>Tyson Christiansen had two hits for Lovell. James led the team with three RBIs.</p>
<p>Mangus pitched four innings for the Mustangs, fanning four Gillette batters.</p>
<p>“By this time the team was having fun and was on a roll,” Spann said. “We had sent four teams home and ten-runned them all. We went with Irving again on the mound and left our defense as is. Irving pitched three good innings for us, only giving up two runs. CJ came up first in the second inning and hit a one-hop triple to the fence that got us rolling for the runs. We relieved Irving in the fourth with Dallen.</p>
<p>“Gillette started the fifth with a hit, but the next batter hit a line drive to Satchel (Ginest) at first for an easy double play. Then Dallen had trouble finding the strike zone. They put up a run on three walks and one hit. I knew Dallen could overpower them, so we went at them right down the pipe with fastballs.</p>
<p>“Tyson came up first in the fifth and hit a shot off the fence but only got a double. Everyone thought it was out. Once again we had no errors, but this game took its toll on us as we had to play all seven innings to get the win. The boys were running out of gas and I could see it.”</p>
<p>In the championship game Saturday, the Mustangs’ run through the tournament came to a stop as they fell to Cheyenne 9-3 to finish second.</p>
<p>James and Rodriguez ripped two hits apiece to lead the team. Rodriguez also led the team with two RBIs.</p>
<p>Rodriguez pitched four innings for Lovell, striking out one Cheyenne batter. Branson Robison pitched one inning, fanning two.</p>
<p>“I was on cloud nine as a coach. We were in the championship game,” Spann said. “We had Carlos on the mound, bats rolling, defense playing error free ball. We got to bat first and that’s what I wanted. I knew if we could get on top and keep the momentum going they would stay energized. Carlos came up second and hit it to right. The kid dove, missed out and Carlos got an inside-the-park home run. That’s just what we needed.</p>
<p>“Carlos pitched four solid innings but started to tire in the fifth so we went to Branson. We also had to sub out Cason in the fifth as he was getting lightheaded from the heat. Cheyenne put up four runs in the fifth, then five in the sixth. The kids ran out of gas. They didn’t quit as they put up two runs in the last inning.”</p>
<p>With the second-place finish, the Mustangs C squad finished the season 23-4-1.</p>
<p>“If we could have made it to Sunday, we would have beaten them,” Spann said. We had CJ back on the mound and would have been rested up. We were a better team than them but had just played too many games. I truly believe we would’ve beat them if we played them on Sunday and I think that coach from Cheyenne knew that.</p>
<p>“What a great group of kids. These boys will be challenging for the state title down the road, and you can count on that.”</p>
<p>Spann said the Mustangs scored 66 runs at the state tournament and only gave up 26. Spann said the team had a batting average of .310 and the pitching staff had an ERA of 2.27.</p>
<p>“We had in my mind the best infield at the tournament,” Spann said. “With CJ at third, Carlos at shortstop, William at second and Tyson at first, we were solid. I think we turned a couple double plays.”</p>
<h6>C State Tournament Results</h6>
<h6>Tuesday, July 17</h6>
<h6>Rock Springs 8, Douglas 6</h6>
<h6>Rawlins 8, Casper 7</h6>
<h6>Laramie 7, Lovell 5</h6>
<h6>Jackson 16, Wheatland 6</h6>
<h6>Wednesday, July 18</h6>
<h6>Gillette 22, Rock Springs 2</h6>
<h6>Cheyenne 20, Rawlins 0</h6>
<h6>Wheatland 14, Douglas 0 – loser out</h6>
<h6>Lovell 14, Casper 4 – loser out</h6>
<h6>Thursday, July 19</h6>
<h6>Lovell 10, Rock Springs 0 – loser out</h6>
<h6>Wheatland 15, Rawlins 5 – loser out</h6>
<h6>Gillette 10, Laramie 9</h6>
<h6>Cheyenne 16, Jackson 6</h6>
<h6>Friday, July 20</h6>
<h6>Wheatland 14, Laramie 4 – loser out</h6>
<h6>Lovell 12, Jackson 2 – loser out</h6>
<h6>Cheyenne 10, Gillette 4</h6>
<h6>Lovell 16, Wheatland 1 – loser out</h6>
<h6>Saturday, July 21</h6>
<h6>Lovell 6, Gillette 3 – loser out</h6>
<h6>Championship game:</h6>
<h6>Cheyenne 9, Lovell 3</h6>
<p style="text-align: right;"><em>By Sam Smith</em></p>
<div id='c1984_0_8' class='sam-container sam-place' data-sam='1'></div>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this story</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-13951" class="share-facebook sd-button share-icon" href="http://www.lovellchronicle.com/2018/07/mustangs-run-gauntlet-at-legion-c-state-to-place-second/?share=facebook" rel="noopener noreferrer" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-13951" class="share-twitter sd-button share-icon" href="http://www.lovellchronicle.com/2018/07/mustangs-run-gauntlet-at-legion-c-state-to-place-second/?share=twitter" rel="noopener noreferrer" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-13951" class="share-google-plus-1 sd-button share-icon" href="http://www.lovellchronicle.com/2018/07/mustangs-run-gauntlet-at-legion-c-state-to-place-second/?share=google-plus-1" rel="noopener noreferrer" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="http://www.lovellchronicle.com/2018/07/mustangs-run-gauntlet-at-legion-c-state-to-place-second/?share=email" rel="noopener noreferrer" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon" href="http://www.lovellchronicle.com/2018/07/mustangs-run-gauntlet-at-legion-c-state-to-place-second/#print" rel="noopener noreferrer" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div>
		
	</div><!-- .entry-content -->

	<footer class="entry-footer">

		
			<div class="entry-tags clearfix">
				<span class="meta-tags">
					<a href="http://www.lovellchronicle.com/tag/2018/" rel="tag">2018</a><a href="http://www.lovellchronicle.com/tag/american-legion/" rel="tag">American Legion</a><a href="http://www.lovellchronicle.com/tag/baseball/" rel="tag">Baseball</a><a href="http://www.lovellchronicle.com/tag/lovell/" rel="tag">Lovell</a><a href="http://www.lovellchronicle.com/tag/lovell-mustangs/" rel="tag">Lovell Mustangs</a><a href="http://www.lovellchronicle.com/tag/wyoming/" rel="tag">Wyoming</a>				</span>
			</div><!-- .entry-tags -->

						
	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="http://www.lovellchronicle.com/2018/07/aron-ronald-schmidt/" rel="prev"><span class="screen-reader-text">Previous Post:</span>Aron Ronald Schmidt</a></div><div class="nav-next"><a href="http://www.lovellchronicle.com/2018/07/lockhart-ranch-and-horseshoe-bend-get-a-new-look/" rel="next"><span class="screen-reader-text">Next Post:</span>Lockhart Ranch and Horseshoe Bend get a new look</a></div></div>
	</nav>
	</footer><!-- .entry-footer -->

</article>

	<div id="comments" class="comments-area">

		
		
			<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span>Leave a Reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/07/mustangs-run-gauntlet-at-legion-c-state-to-place-second/?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3A+Lovellchroniclecom+%28lovellchronicle.com+RSS%29#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://www.lovellchronicle.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='13951' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="f38dfc6075" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="33"/></p>			</form>
			</div><!-- #respond -->
	
	</div><!-- #comments -->

		
		</main><!-- #main -->
	</section><!-- #primary -->
	
	
	<section id="secondary" class="sidebar widget-area clearfix" role="complementary">

		<div class="widget-wrap"><aside id="search-5" class="widget widget_search clearfix">
<form role="search" method="get" class="search-form" action="http://www.lovellchronicle.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field"
			placeholder="Search &hellip;"
			value="" name="s"
			title="Search for:" />
	</label>
	<button type="submit" class="search-submit">
		<span class="genericon-search"></span>
		<span class="screen-reader-text">Search</span>
	</button>
</form>
</aside></div><div id='c9812_0_16' class='sam-container sam-place' data-sam='0'><a  href='http://www.basinrepublican-rustler.com/classifieds/' target='_self'><img src='http://www.lovellchronicle.com/wp-content/uploads/2018/04/ClassAds-1.jpg'  alt=''  /></a></div><div id='c8834_0_12' class='sam-container sam-place' data-sam='0'><script src='https://adsmopress.com/ads-state.php?u=423&s=2&d=WY' type='text/javascript'></script></div><div id='c1123_0_13' class='sam-container sam-place' data-sam='0'><a  href='http://www.hyarttheatre.com' target='_self'><img src='http://www.lovellchronicle.com/wp-content/uploads/2017/12/Hyart_Web17.gif'  alt=''  /></a></div><div id='c7661_0_14' class='sam-container sam-place' data-sam='0'><a  href='https://www.bighornfederal.com' target='_self'><img src='http://www.lovellchronicle.com/wp-content/uploads/2017/12/BHF_WEB-AD.jpg'  alt=''  /></a></div><div id='c5658_0_15' class='sam-container sam-place' data-sam='0'><a  href='https://flyyra.com' target='_self'><img src='http://www.lovellchronicle.com/wp-content/uploads/2018/05/YRA_WEB-AD_300x250.jpg'  alt=''  /></a></div><div class="widget-wrap"><aside id="text-3" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">weather</h3></div>			<div class="textwidget"><div style='width: 300px; height: 250px; background-image: url( http://vortex.accuweather.com/adcbin/netweather_v2/backgrounds/lhtblue_300x250_bg.jpg ); background-repeat: no-repeat; background-color: #3BA6C9;' ><div id='NetweatherContainer' style='height: 238px;' ><script src='http://netweather.accuweather.com/adcbin/netweather_v2/netweatherV2ex.asp?partner=netweather&tStyle=whteYell&logo=1&zipcode=82431&lang=eng&size=9&theme=lhtblue&metric=0&target=_self'></script></div><div style='text-align: center; font-family: arial, helvetica, verdana, sans-serif; font-size: 11px; line-height: 12px; color: #FFFFFF;' ><a style='color: #FFFFFF' href='http://www.accuweather.com/us/wy/lovell/82431/city-weather-forecast.asp?partner=accuweather' >Weather Forecast</a> | <a style='color: #FFFFFF' href='http://www.accuweather.com/maps-satellite.asp' >Weather Maps</a> | <a style='color: #FFFFFF' href='http://www.accuweather.com/index-radar.asp' >Weather Radar</a></div></div></div>
		</aside></div><div class="widget-wrap"><aside id="cd_fbsp_like_widget-5" class="widget cd-fb-like-widget clearfix"><div class="widget-header"><h3 class="widget-title">Follow Us on Facebook</h3></div><fb:like-box href="http://www.facebook.com/pages/Lovell-Chronicle/123118627745521" width="300" height="160" border_color="white" show_faces="true" stream="false" header="false"></fb:like-box></aside></div>
	</section><!-- #secondary -->

	

	</div><!-- #content -->

	
	<div id="footer" class="footer-wrap">

		<footer id="colophon" class="site-footer container clearfix" role="contentinfo">

			
			<div id="footer-text" class="site-info">
				
	<span class="credit-link">
		Powered by <a href="http://wordpress.org" title="WordPress">WordPress</a> and <a href="https://themezee.com/themes/tortuga/" title="Tortuga WordPress Theme">Tortuga</a>.	</span>

				</div><!-- .site-info -->

		</footer><!-- #colophon -->

	</div>

</div><!-- #page -->


<!-- BEGIN Clicky Analytics v1.4.8 Tracking - https://deconf.com/clicky-analytics-dashboard-wordpress/ -->
<script type="text/javascript">
var clicky_site_ids = clicky_site_ids || [];
clicky_site_ids.push(100712713);
(function() {
  var s = document.createElement('script');
  s.type = 'text/javascript';
  s.async = true;
  s.src = '//static.getclicky.com/js';
  ( document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0] ).appendChild( s );
})();
</script>
<noscript><p><img alt='Clicky' width='1' height='1' src='//in.getclicky.com/100746374ns.gif' /></p></noscript>
<!-- END Clicky Analytics v1.4.8 Tracking - https://deconf.com/clicky-analytics-dashboard-wordpress/ -->
    <div id="fb-root"></div>
    <script>(function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0];
      if (d.getElementById(id)) return;
      js = d.createElement(s); js.id = id;
      js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
      fjs.parentNode.insertBefore(js, fjs);
    }(document, 'script', 'facebook-jssdk'));</script>
    <!-- begin visitor maps  -->
<script type="text/javascript">
//<![CDATA[
function wo_map_console(url) {
  window.open(url,"wo_map_console","height=650,width=800,toolbar=no,statusbar=no,scrollbars=yes").focus();
}
//]]>
</script>
<!-- end visitor maps -->
<!-- Powered by WPtouch: 4.3.28 -->	<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/www.lovellchronicle.com\/2018\/07\/mustangs-run-gauntlet-at-legion-c-state-to-place-second\/":13951};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/2018/07/mustangs-run-gauntlet-at-legion-c-state-to-place-second/?utm_source=feedburner&#038;utm_medium=feed&#038;utm_campaign=Feed%3A+Lovellchroniclecom+%28lovellchronicle.com+RSS%29" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="http://www.lovellchronicle.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='http://www.lovellchronicle.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":0,"isRTL":false});});
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"http:\/\/www.lovellchronicle.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201830'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-includes/js/comment-reply.min.js?ver=4.9.7'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-content/plugins/page-links-to/js/new-tab.min.js?ver=2.11.1'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=12.0'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-includes/js/wp-embed.min.js?ver=4.9.7'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-content/plugins/jetpack/_inc/build/spin.min.js?ver=1.3'></script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-content/plugins/jetpack/_inc/build/jquery.spin.min.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"http:\/\/www.lovellchronicle.com\/wp-admin\/admin-ajax.php","nonce":"0fc56572ba","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"http:\/\/www.lovellchronicle.com\/wp-login.php?redirect_to=http%3A%2F%2Fwww.lovellchronicle.com%2F2018%2F07%2Fmustangs-run-gauntlet-at-legion-c-state-to-place-second%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=20170209'></script>
<script async="async" type='text/javascript' src='http://www.lovellchronicle.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.lovellchronicle.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=6.3.2'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201830.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.3.2',blog:'23520868',post:'13951',tz:'-6',srv:'www.lovellchronicle.com'} ]);
	_stq.push([ 'clickTrackerInit', '23520868', '13951' ]);
</script>

</body>
</html>
